Unable to debug Griffon code

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Unable to debug Griffon code

Marcelo
Hi,
I am wondering if anyone can tell me exactly how I can debug the Griffon code.
What I did so far is this:

- Cleaned the project: "gradle clean"
- Removed the gradle cache directory: "rm -r $HOME/.gradle"
- Cloned Griffon 2.9.1: "git clone -b master https://github.com/griffon/griffon.git"
- Compiled with Debugging: "gradle -PwithDebug=true build" (it built successfully)
- Installed to Maven Local: "gradle publishToMavenLocal"
- Rebuilt  the project refreshing dependencies:  "gradle build --refresh-dependencies"

When I start the IDE (Netbeans) the debugger complains the source code was compiled without the -g option, so I cannot see the value of different variables within Griffon.
Any ideas on how to do this properly?
Thanks!
Marcelo.
Reply | Threaded
Open this post in threaded view
|

Re: Unable to debug Griffon code

aalmiray
Administrator
Hi Marcelo,

Support for the `withDebug` project property was removed in 2.9.1 as it caused trouble computing code-coverage. As a matter of fact 2.9.0 shipped without debug information but 2.9.1 should work, at least it does on IntelliJ.

Cheers,
Andres
Reply | Threaded
Open this post in threaded view
|

Re: Unable to debug Griffon code

Marcelo
Hi Andres,

Thanks for getting back. I saw the compiling information with the 'withDebug' property in the BUILDING.adoc for version 2.9.1
So from now on will the source be compiled with debugging information enabled by default?
Thanks!

Marcelo.
 
Reply | Threaded
Open this post in threaded view
|

Re: Unable to debug Griffon code

aalmiray
Administrator
Hi Marcelo,

Yes, that's the case.

Cheers,
Andres